aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHimbeerserverDE <himbeerserverde@gmail.com>2023-11-18 18:10:15 +0100
committerHimbeerserverDE <himbeerserverde@gmail.com>2023-11-18 18:10:15 +0100
commit5d09cfc284c93ba2fadb648810b1a7bc5d1a779c (patch)
tree87dbfc1c7d94f9ed9a203601185fa1526ff4c06f /Cargo.toml
parent639ab976b8d526a8f0a296d6577dce7715109fff (diff)
use netlinklib to wait for wan
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 46ca0e8..a4f332d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,7 +10,7 @@ chrono = "0.4.31"
hickory-resolver = { version = "0.24.0", default-features = false, features = ["tokio-runtime"] }
nix = { version = "0.26.2", features = ["time"] }
ntp = "0.5.0"
-rsdsl_ip_config = { git = "https://github.com/rsdsl/ip_config.git", version = "0.2.4" }
+rsdsl_netlinklib = { git = "https://github.com/rsdsl/netlinklib.git", version = "0.4.5", default-features = false, features = ["status"] }
thiserror = "1.0"
tokio = { version = "1.0", features = ["macros", "time", "fs", "signal"] }