aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <gharris@sonic.net>2022-09-28 00:02:32 -0700
committerGuy Harris <gharris@sonic.net>2022-09-28 00:02:32 -0700
commiteedad18ebf1d800ee7266250f8d0f4d59a91fd5e (patch)
tree983ae35aaa81b6aa1979b3eab8b55d20b00cc292 /CMakeLists.txt
parentd972b0ea1e48ea5d7140b129f784007341446fbd (diff)
cmake: add -ldlpi, not just dlpi, to LIBS_PRIVATE.
It's a list of -l flags, not a list of library names, as it's put into a libpcap.pc file in the Libs.private entry.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 67f97652..15db41e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1522,7 +1522,7 @@ else(WIN32)
#
set(PCAP_LINK_LIBRARIES ${PCAP_LINK_LIBRARIES} dlpi)
set(LIBS_STATIC "${LIBS_STATIC} -ldlpi")
- set(LIBS_PRIVATE "${LIBS_PRIVATE} dlpi")
+ set(LIBS_PRIVATE "${LIBS_PRIVATE} -ldlpi")
set(PCAP_TYPE libdlpi)
endif()