aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHenauxg <19689618+Henauxg@users.noreply.github.com>2022-10-17 22:42:12 +0200
committerHenauxg <19689618+Henauxg@users.noreply.github.com>2022-10-17 22:42:12 +0200
commitbf4a3a5dafe9b2d647b43d75156e2bd98155f8bb (patch)
tree47f988f7176bc2f2641e310801b89875f1fdd134 /Cargo.toml
parent30bb7c96599b79e5d59881e84a4ec8135d3c9adf (diff)
Initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..b8cdd86
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "bevy_quinnet"
+version = "0.1.0"
+keywords = ["gamedev", "networking", "quic", "quinn", "bevy"]
+description = "Bevy plugin for Client/Server multiplayer games using QUIC"
+edition = "2021"
+
+[dependencies]
+bincode = "1.3.3"
+serde = "1.0.145"
+bevy = { version = "0.8.1", default-features = false, features = [] }
+rustls = { version = "0.20.6", default-features = false, features = ["quic","dangerous_configuration"] }
+tokio = { version = "1.21.2", features = ["sync", "rt-multi-thread", "macros"] }
+tokio-util = { version = "0.7.4", features = ["codec"] }
+rcgen = "0.10.0"
+quinn = "0.8.5"
+rand = "0.8.5"
+futures-util = "0.3.24"
+futures = "0.3.24"
+bytes = "1.2.1"