aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 1 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0a260c0..d75fab0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,17 +6,11 @@ edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-bitfield = "0.14.0"
-futures = "0.3.28"
-futures-util = "0.3.27"
ipnet = "2.8.0"
-libc = "0.2.149"
-netlink-packet-route = "0.17.0"
rsdsl_ip_config = { git = "https://github.com/rsdsl/ip_config.git", version = "0.2.4" }
+rsdsl_netlinklib = { git = "https://github.com/rsdsl/netlinklib.git", version = "0.1.2", features = ["blocking"] }
rsdsl_pd_config = { git = "https://github.com/rsdsl/pd_config.git", version = "0.1.0" }
-rtnetlink = "0.13.1"
serde_json = "1.0"
signal-hook = "0.3.17"
sysinfo = "0.29.10"
thiserror = "1.0"
-tokio = { version = "1.26.0", features = ["rt-multi-thread"] }